Some card transactions are declining
Incident Report for FairFX
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 10:53 BST
Monitoring
We have identified an issue at Mastercard that was causing payments to decline and believe this has been resolved. Cards should be working normally, however we are continuing to monitor the situation with Mastercard.
Posted Jul 21, 2021 - 10:26 BST
Investigating
Some payments on FairFX cards are declining. We're investigating this with our suppliers and working to resolve this as soon as possible. We will update you as soon as we have more information
Posted Jul 21, 2021 - 09:20 BST
This incident affected: 💳 Card Payments.